Limit SAML support to Python <= 3.10

Review Request #69 — Created Sept. 30, 2022 and discarded

guest3897
Review Board
guest1530
The `python3-saml` in our SAML dependencies requires `lxml < 4.7.1`, however this
fails to compile on Python 3.11. This change skips the SAML dependencies when
setting up for Python 3.11.

Testing Done:
Ran `python3.11 ./setup.py develop` successfully.

Reviewed at https://reviews.reviewboard.org/r/12592/


guest3897
Review request changed

Status: Discarded

Change Summary:

testing only

Loading...